[Samba] change SOA record

Rauer, Frank rauer at optovision.de
Thu Nov 10 12:21:52 UTC 2016

Hello list..:-)

i have a little problem and don´t find a solution for it.
Some time ago our first DC died and I replaced it with a new one with a 
different name but the same IP.didn´t want to change the DNS entry in 
all the clients.
Guess since than the dynamic DNS update wasn´t working anymore, so I 
tried to find out the reason.

What I found is that the SOA record was pointing still to the none 
existing DC. After searching a little bit I was able to change the SOA 
record for our Forward-lookupzone and the first workstations have been 
registered in the DNS...till today not enough.

But I was only able to change the SOA record for our first 
"samdom.example.com" zone. For the "_msdcs.samdom.example.com" zone it´s 
not possible. I use exactely the same syntax...no success.

With dig -t SOA _msdcs.samdom.example.com I get every information about.
When I try to change it I get only a message "ERROR: Record does not exist"

At the moment we´re on 4.4.6, but also in a testsystem with 4.5.1 I get
the same result.

Has anybody an idea how to fix it ?



More information about the samba mailing list