[Samba] After some time 4.3.9 Member Server in different Subnet than ADS controller loses trust

Thomas Burger (tburger@eritron.de) tburger at eritron.de
Sat May 28 12:13:47 UTC 2016

Hello Louis, hello Rowland,

I have worked on this topic the last days trying your suggestions, but 
stumbled accidentially over two things.

1. on my DC in /etc/hosts the entry for the FQDN and shortname of the DC 
referred to (which is clearly not what should be there - I 
guess this has forgotten during my reinstall of the ADS controller). I 
changed this to reflect the real IP-Address as mentioned as well in 
https://help.ubuntu.com/community/ActiveDirectoryWinbindHowto .

2. I could not get rid of the feeling that something is wrong with the 
naming resolution and while digging a little deeper into other smb.conf 
options I recognized a typo in my config:
"name resolve order = hosts wins bcast" must not have the "s" at the end 
of the "host" so I changed it to "name resolve order = host wins bcast"

I canĀ“t say 100% that these two changes solved my problems because 
Ubuntu just released another 4.3.9 Version of their Samba package while 
I was doing the change (and of course I tried installing it) but so far 
it looks promising.

Again thanks for your help. Will keep it in mind if this turns out not 
to be as hoped.
Best regards and have a great weekend


More information about the samba mailing list