[Samba] Fwd: Re: Invalid data for index DN=@INDEX:OBJECTCLASS:DNSNODE

Rowland penny rpenny at samba.org
Fri May 13 16:41:10 UTC 2016

On 13/05/16 17:19, ash-samba at comtek.co.uk wrote:
>> First things first, is there anyway you can update Samba ?
>> The 4.1.X series is now EOL and wasn't patched for badlock, depending 
>> on what version of debian you are running, you should be able to 
>> upgrade easily.
> 0 root at empire:/etc/apt[0] samba-tool -V
> 4.2.10-Debian
> 0 root at empire:/etc/apt[0] dpkg -s samba |grep ^Ver
> Version: 2:4.2.10+dfsg-0+deb8u2
> 0 root at empire:/etc/apt[0] uname -a
> Linux empire 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt25-2 (2016-04-08) 
> x86_64 GNU/Linux
>> Have you tried running 'samba-tool dbcheck' ??
> 0 root at empire:/etc/apt[0] samba-tool dbcheck
> Checking 723 objects
> Checked 723 objects (0 errors)
> We have the same inability to add records.
> We have the same error running: /usr/bin/samba-tool drs replicate 
> empire.chester-dc.example.com alaska.chester-dc.example.com 
> DC=DomainDnsZones,DC=chester-dc,DC=example,DC=com --local
> Thanks, but it doesn't seem like the upgrade has helped.

OK, could this just be a permissions problem i.e. user 'ash' doesn't 
have the required rights to add a dns record, try again, but this time 
use the 'Administrator' user.


More information about the samba mailing list