[Samba] Unable to demote DC

Chris Hastie lists at oak-wood.co.uk
Thu Mar 24 11:44:31 UTC 2016

On 23/03/2016 11:31, Denis Cardon wrote:
> which version of samba are you using? 4.4 or below?

Hi, thanks for your suggestions.

I have version 4.1.6 on two DC should remain (from Ubuntu 14.04 LTS 
packages). The one I'm trying to demote is actually 4.3.4 from the 
Zentyal repositories.
> is the sogo3.ad.oak-wood.co.uk server still running ok or do you have
> replication problem on that server?
I have three DCs, oak, sogo3 and zent1. As far as I can tell replication 
between sogo3 and oak is fine, although occassionally flaky (sometimes I 
have to restart them to get them synced). Replication between zent1 and 
the others has never really worked, which is one of the reasons I want 
to demote it. I've also tried doing the demote on zent1 with 
--server=oak.ad.oak-wood.co.uk to force the choice of server to partner 
with, but with the same effect.

> Server demotion has been a common issue for quite some time. Could you
> try to upgrade to 4.4 and run the samba-tool demote with the
> --remove-other-dead-server flag?
> Otherwise you can demote by hand cleaning up the LDAP and DNS on the DC
> that is still running properly.

Of the two options which would you recommend? I'm retiscent to compile 
4.4 from source as I try to keep everything on Ubuntu LTS and standard 
repositories. On the other hand, hand cleaning sounds like it could be 
fraught with problems and gotchas



More information about the samba mailing list