[Samba] Samba AD/DC crashed again, third time in as many months

IT Admin it at cliffbells.com
Thu Mar 3 00:08:13 UTC 2016

Hi Marc,

I added "log level = 10" to my smb.conf, the new log is here:

The initial failure of this domain occurred in mid-december, I associated
it with a failure of the raid array after an ubuntu upgrade, however, I
suspect that wasn't really the case.  I rebuilt the domain, it failed again
about a week later with roughly the same behaviour as I'm seeing now.  I
worked with the samba-users group over a period of about three weeks to
troubleshoot the issue, we settled on my database being corrupted beyond
repair, at the time I believed CrashPlan backup was to blame, but again I
suspect that may not have been the case, or at least it wasn't the only
issue in play.  I removed all Canonical samba packages, downloaded the
latest samba source from samba.org, compiled and installed samba 4.3.3.  I
then provisioned the current domain and rebuilt their infrastructure after
which I worked with Rowland a bit to implement the samba_backup script.
The domain seemed fine up until about two weeks ago at which time I started
seeing failures in log.samba, typically referencing dns update failures and
NT_STATUS_UNAVAILABLE etc.  A reboot of the DC always brought samba back, I
had hoped upgrading to the latest release would alleviate those issues.
Unfortunately the entire thing fell apart this morning, samba failing to
start, their entire domain is noon-functional.

I'm not sure how to verify all other unwanted samba packages are gone, what
would you suggest?

I look forward to any guidance you may be able to offer.

On Wed, Mar 2, 2016 at 5:42 PM, Marc Muehlfeld <mmuehlfeld at samba.org> wrote:

> Am 02.03.2016 um 18:52 schrieb IT Admin:
> > Samba is compiled from source.
> > Samba DB is stored on local RAID array.
> > Changes to AD are done using ADUC from a Windows 7 box.
> > AD is used for authentication, user shares (folder redirection), and
> shared
> > folders.
> Can you add
>   log level = 10
> to your smb.conf, empty your log directory and start Samba. It should
> generate a new log, that captures all output. Then put it to cpaste.org
> or some other paste service and share the link with us. Maybe we see
> something interesting.
> Does something changed when the problem occured the first time? Some
> package updates, crashes, etc.?
> Can you make sure that no kind of Samba package (daemon, libs, etc.) is
> installed on the system? Maybe your selfcompiled version overwrites some
> stuff and your OS installed an update, that mixes now with the self
> compiled version. Just a guess.
> Regards,
> Marc

More information about the samba mailing list