[Samba] FSMO / ldbsearch

Rowland penny rpenny at samba.org
Thu Jun 23 15:23:32 UTC 2016

On 23/06/16 15:47, Jonathan Hunter wrote:
> Hi,
> After a couple of unfortunate hardware failures and some not insignificant
> amount of work to rebuild two of my DCs, I am trying to check that things
> are now working correctly.
> Looking at the wiki page on FSMO ownership, one suggestion is to run the
> following ldbsearch command.. but this doesn't work for me.
> root at dc2:~# ldbsearch --cross-ncs -H /var/lib/samba/private/sam.ldb -b
> "CN=Infrastructure,DC=DomainDnsZones,DC=mydomain,dc=org,dc=uk" -s base
> fsmoroleowner
> search failed - Unsupported critical extension 1.2.840.113556.1.4.1340
> root at dc2:~# samba -V
> Version 4.4.4
> Has something changed since the wiki page was created? Or is something
> broken at my end? :) I can't say I have run this command before, so I don't
> know if it worked previously.
> Cheers,
> Jonathan

Well, quite a lot has changed since the wiki page was written, but 
nothing to do with FSMO.
It looks like you have a problem, have you tried running 'samba-tool 
dbcheck' ?


More information about the samba mailing list