[Samba] FSMO / ldbsearch

Jason Waters jason at geeknocity.com
Thu Jun 23 15:00:52 UTC 2016

I just tried running it on Ubuntu 14.04 and that command works for me(with
my details).  It sounds like and issue with your ldbsearch.  Not sure if
you want to but if you send the sam.ldb I can try running it on my machine
as well.  But might have some sensitive things in there.

On Thu, Jun 23, 2016 at 10:47 AM, Jonathan Hunter <jmhunter1 at gmail.com>

> Hi,
> After a couple of unfortunate hardware failures and some not insignificant
> amount of work to rebuild two of my DCs, I am trying to check that things
> are now working correctly.
> Looking at the wiki page on FSMO ownership, one suggestion is to run the
> following ldbsearch command.. but this doesn't work for me.
> root at dc2:~# ldbsearch --cross-ncs -H /var/lib/samba/private/sam.ldb -b
> "CN=Infrastructure,DC=DomainDnsZones,DC=mydomain,dc=org,dc=uk" -s base
> fsmoroleowner
> search failed - Unsupported critical extension 1.2.840.113556.1.4.1340
> root at dc2:~# samba -V
> Version 4.4.4
> Has something changed since the wiki page was created? Or is something
> broken at my end? :) I can't say I have run this command before, so I don't
> know if it worked previously.
> Cheers,
> Jonathan
> --
> "If we knew what it was we were doing, it would not be called research,
> would it?"
>       - Albert Einstein
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list