[Samba] Samba4 Domain Member Server "Getent show diferents UID"

Juan Ignacio juan.ignacio.pazos at gmail.com
Mon Jun 13 18:37:16 UTC 2016


I'll use this email from now, the other does not work well.

A few years ago around 2.

We did everything that could be used for NIX and it worked.
The main DC_AD had been provisioned without rfc2307 and we did later.

The problem is that at that time by not having infrastructure had to be
used as fileserver and this was a problem because all directories are UID
of 3000000 onwards.

Now I installed a new server following the procedure here:


All seems to work well but UIDs are different when for example I run
wbinfo --user-info = uanaco

Primary AD-DC
ADDC1 \ uanaco: *: 3000783: 100: uanaco: / home / ADDC1 / uanaco: / bin /

member Server
uanaco: *: 100642: 100008: uanaco: / home / ADDC1 / uanaco: / bin / false

This is a problem because my intention is to use this file server and
testify pass all directories Primary AD-DC to Member Server.

Is there any way the member server read the same UID as the primary-

Thank Rowland.

More information about the samba mailing list