[Samba] Lost remote access to /

Jeremy Allison jra at samba.org
Sat Jan 30 07:51:28 UTC 2016

On Fri, Jan 29, 2016 at 03:47:52PM -0800, Paul D. DeRocco wrote:
> For a long time, I've had a share set up on my Samba server (Ubuntu 14.04)
> that gives me read/write access to /. (It's a machine that does Yocto
> Linux builds, nothing proprietary on it.) I routinely accessed it from a
> couple of Win7 boxes and one Mac. A few days ago, I installed some Ubuntu
> updates, and suddenly the share stopped working. I could open the machine,
> and I could open the share and see all the first level directories and a
> few files, but I'd get an error like "Windows cannot access
> \\BUILD\all\home" when I tried to open the home directory. I get analogous
> errors on the Mac, too.
> I tried adding "force user = root". I tried "smbpasswd -a root" to supply
> the root password. I tried adding "valid users = root". If I share
> anything other than /, then it works fine. What could have changed all of
> a sudden? Was there a global policy change in Samba that rules out sharing
> /, that suddenly appeared in that fatal update?
> Here's my smb.conf (with the printer stuff and comments stripped):

You might be hitting bug:


Can you try the patch there ?

More information about the samba mailing list