[Samba] [samba4] DNS updates

Rowland penny rpenny at samba.org
Thu Jan 28 10:05:22 UTC 2016

On 28/01/16 09:11, mathias dufresne wrote:
> No replication this morning but FSMO was rebooted yesterday. Only joined DC
> were rebooted.
> After verifying all A records related to new DC were created, I forced
> creation of replication related DNS entries as described there :
> https://wiki.samba.org/index.php/Check_and_fix_DNS_entries_on_DC_joins#Resolve_the_objectGUID_CNAME_record_of_the_new_joined_Domain_Controller
> I forced replication (drs replicate) from a replicated DC to all 10 new DC
> and also force replication in the other way. All drs replicate commands
> worked well.
> Back to newly joined DC I launched samba_dnsupdate, on 10 DC this command
> failed on 9 DC with mesage: "update failed: NOTAUTH". I rebooted all joined
> DC and samba_dnsupdate worked well on them.
> This gave time to Samba to replicate things around and now all things goes
> well.
> Joining new DC is still a bit tricky in my opinion. Hoping this would work
> better with 4.4.x
> Cheers,
> mathias

When you provision a domain, all the dns records are created during the 
provision, but when you join a DC to a domain they aren't. You need to 
restart Samba on the newly joined DC, once Samba is restarted, 
samba_dnsupdate will be run, this reads the file 'dns_update_list' and 
then adds (if needed) the records it finds in the file. If you do not 
restart Samba, the dns records do not get added and your problems start.


More information about the samba mailing list