[Samba] Samba 4 and Windows 10 Problem.

Rodrigo Yoshioka ro_yoshioka2002 at yahoo.com.br
Tue Jan 19 09:41:46 UTC 2016

Hi Daniel, 
In that example that I wrote, I didn't create users yet, because I did public share only, but windows tell that I don't have permission. Do I need to create groups and users to that situation too?

But when I add private share, I create local users (add user) and samba user, but when I type user and password Samba answer that I don't have permission too.I think the problem might be that when Windows asks me for credentials It sends local windows account instead what I'm typing.I have already tried to create same users I have in Windows but no success too.

After a lot of thinking and reading I tried some tutorials on the internet, without success too.

 I have already tried to change windows 10 smb version too... and not working too.
I don't know what to do now.


    Em Terça-feira, 19 de Janeiro de 2016 5:09, Mueller <mueller at tropenklinik.de> escreveu:

 Where do you get your users and groups, local?
Did you map the local users and groups to match with samba4/winbind?

EDV Daniel Müller

Leitung EDV
Tropenklinik Paul-Lechler-Krankenhaus
Paul-Lechler-Str. 24
72076 Tübingen 
Tel.: 07071/206-463, Fax: 07071/206-499
eMail: mueller at tropenklinik.de
Internet: www.tropenklinik.de 

-----Ursprüngliche Nachricht-----
Von: Rodrigo Yoshioka [mailto:ro_yoshioka2002 at yahoo.com.br] 
Gesendet: Dienstag, 19. Januar 2016 00:24
An: samba at lists.samba.org
Betreff: [Samba] Samba 4 and Windows 10 Problem.

I'm used to configure samba 3, and now I'm getting some problems using samba 4.
My scenario: I have a file server which hosts need to access public folders and private folders.OS: Centos7Samba version: 4.2.3  | 11.el7_2Selinux DisabledFirewalld disabled smb.conf[global]workgroup = WORKGROUP server string = Samba Server %v netbios name = centossecurity = usermap to guest = bad userdns proxy = no#============================ Share Definitions ==============================[Anonymous]path = /home/suporte/semsenhabrowsable =yeswritable = yesguest ok = yesread only = noguest only = yescreate mode = 0777directory mode = 0777

folder permissionsdrwxrwxrwx. 2 nobody nobody 6 Jan 18 20:18 semsenha Of course there isn't private folders configured yet, but I couldn't make it work with just this.
I can make it work without password if I put "guest account = root" at global area, and "root = root" at shares area, but after that Private folders doens't work.At moment I use smbpasswd, public share stop working too.
The clients are Windows 10 without domain controller. I use Workgroup Network

Can anyone help me please?


To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba


More information about the samba mailing list