[Samba] Samba installation

Rowland penny rpenny at samba.org
Fri Jan 15 16:32:42 UTC 2016

On 15/01/16 12:20, Saurabh Shah wrote:
> I followed the samba installation wiki. First I installed all the 
> required dependency packages and they were installed successfully.
> Next I followed the system requirements instructions.
> After that I downloaded the latest version of samba and extracted it.
> After this I tried to configure samba but I got the above error.
> I have installed python 3 and python 2 both but python 2 is set as 
> default.

OK, I installed ubuntu 15.10 server in a VM.

Before I could start to build Samba I had to sort the mess (this is my 
opinion) that ubuntu laughingly calls the network.

For a start, I couldn't give the server a fixed ip during the install 
and this was on something called 'ubuntu-15.10-server-i386.iso' !! and 
then when I logged in after the install, I found that dhcp hadn't worked 
and the VM didn't have an ip.

So this is what I did to make the network work:

altered /etc/network/interfaces

auto enp0s3
iface enp0s3 inet static

removed resolvconf

reset /etc/resolv.conf

search example.com

changed /etc/hosts, having pointing to the hostname isn't a 
good idea (well, when it comes to Samba4, it isn't) localhost    ubu15.example.com    ubu15

Rebooted and then found that 'apt-get update didn't work, traced this to 
/etc/resolv.conf being a symlink to a file in /run (I HATE SYSTEMD)
removed the symlink and recreated /etc/resolv.conf again, now 'apt-get 
update' worked
ran 'apt-get upgrade' and then installed:

sudo apt-get install acl attr autoconf bison build-essential debhelper 
dnsutils docbook-xml docbook-xsl flex gdb krb5-user libacl1-dev 
libaio-dev libattr1-dev libblkid-dev libbsd-dev libcap-dev libcups2-dev 
libgnutls28-dev libjson-perl libldap2-dev libncurses5-dev libpam0g-dev 
libparse-yapp-perl libpopt-dev libreadline-dev perl perl-modules 
pkg-config python-all-dev python-dev python-dnspython python-crypto 
xsltproc zlib1g-dev

Moved to /usr/src

Got the latest Samba:
sudo wget https://www.samba.org/samba/ftp/samba-latest.tar.gz

Unpacked it:
sudo tar zxf samba-latest.tar.gz

Moved into the directory created by the above command:
cd samba*

Then compiled it:
sudo ./configure
sudo make
sudo make install

This all completed without error.


More information about the samba mailing list