[Samba] Samba AD with Microsoft Account

Viktor Trojanovic viktor at troja.ch
Wed Jan 13 10:30:34 UTC 2016

No, that's not normal behavior, and I assume that's what's responsible for those other issues you're experiencing.

I suggest you analyze your Samba installation thorougly using the information in the Wiki (there is a lot and in 90% problems can be solved or at least clearly identified with it). If it's just a lab setup, you might consider provisioning a new AD entirely. If you can't solve it on your own, start a new thread explaining your installation (network setup, smb.conf, dns etc), what you did to troubleshoot including the results, and where you're stuck. Leave out the MS or Office account stuff for now as it's not Samba relevant. 


> On 13 Jan 2016, at 06:11, Jean-Philippe Steinmetz <caskater47 at gmail.com> wrote:
> Well I tried using a regular user and no improvement. I was also having
> problems creating users using the Active Directory Users and Computers tool
> from within Windows. I had to log into the AD and create the user from the
> shell directly. I am however able to make changes to existing users and
> groups as well as add new groups through the Windows tools.
> I've also found some errors with some of the other tools. Is this normal
> behavior? I would expect all the RSAT tools work correctly.
>> On Tue, Jan 12, 2016 at 12:13 PM, Viktor Trojanovic <viktor at troja.ch> wrote:
>> No. Like I said, I'm pretty sure Samba's not to blame here.
>> I also think that a MS account cannot be linked to any kind of admin
>> account - for a good reason. It's the same with Edge or MS Store, they
>> won't open on an admin account.
>> Create a regular user and try again.
>> Viktor
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list