[Samba] Samba after upgrade+migration, Win7 workstation trusts lost

Dave Beach drbeach4 at gmail.com
Mon Feb 29 01:15:56 UTC 2016

Hello list -


>From my previous post:




First, trusts have been lost with the Win7 workstations in the domain. I
would like to recover those trusts with no effect to the user accounts on
the workstations. All workstations use local profiles. I can log on to the
workstations using cached credentials, but any attempt to log on to them
with Samba running on the server fails. So, I stop Samba on the server, log
on to the workstations, restart Samba on the server. Doing this, I can map
drives on the workstations to shares on the server.




I thought about this a bit more, and wondered if I was actually having some
sort of problem with the entries in the passwd and shadow files on the
server, and an interaction between them and the samba passdb (ldap). I had
recreated the unix accounts manually, but I thought I'd try an experiment
and comment out those lines and replace them with the matching lines from
the passwd and shadow files from the old server.


I tried logging on to my own workstation, and things seemed to work - my
netlogon was processed, drives were mapped. I'm pretty sure my wife heard me
yelling with success all the way upstairs. I then went upstairs to her
workstation and tried to log on, only to get the now-familiar message about
the lost trust to the domain. Puzzled, I went back downstairs to my
workstation, logged out, and tried to log back on. No luck whatsoever, same
message about lost trust. Nothing changed on the server between the first
time I apparently successfully logged on, and the second time when I was
unable to log on.


Huh? I am extremely confused. I'll need to slog through quite a bit of log
data, but this makes no sense to me at all.


More information about the samba mailing list