[Samba] Samba + ldap + cannot find domain

Dave Beach drbeach4 at gmail.com
Fri Feb 19 01:24:54 UTC 2016

> Is ldap running on the Samba machine ?

Yes, this is the only server in the domain.

> Have you set the ldap password with 'smbpasswd -w'

Yes, and based on log.smbd Samba can connect .

> I would remove this line: server role = standalone server You are not running a standalone server.

The parameter is new since the previous version of Samba I was running (v3.5.6), and wasn't in my previous smb.conf. I figured I'd take the approach of starting with the sample smb.conf with the new installation, make my way through it, and add whatever seemed necessary from my previous smb.conf. I presumed that "standalone" meant no other server, which is true. Looking more closely at the documentation, I figure I probably want "classic primary domain controller".

Hmm. I wonder what happens if I change to that. (a few minutes later) Okay, that solved the "looking for wrong domain" problem; the log file now says it's looking for the correct domain - but cannot find it.

> What have you got in /etc/hosts ?

I'll come back to this in a second.

> It may work better if you change the passdb line to 'passdb backend = ldapsam'

Ok, trying this.  (a few minutes later) Nope, same result.

Back to /etc/hosts: localhost drbgate.drbhome.ca drbgate

> Can you also post the log where it shows asking for the wrong domain.

Now looking for the correct domain, but still throwing an error (leaving off earlier log lines that don't seem to be relevant to the problem, and don't indicate any errors):

[2016/02/18 20:12:07.200064,  2] ../source3/lib/interface.c:341(add_interface)
  added interface eth1 ip= bcast= netmask=
[2016/02/18 20:12:07.209878,  3] ../source3/smbd/server.c:1248(main)
  loaded services
[2016/02/18 20:12:07.211751,  3] ../source3/smbd/server.c:1280(main)
  Becoming a daemon.
[2016/02/18 20:12:07.216706,  2] ../source3/passdb/pdb_ldap_util.c:280(smbldap_search_domain_info)
  smbldap_search_domain_info: Searching for:[(&(objectClass=sambaDomain)(sambaDomainName=DRBHOME))]
[2016/02/18 20:12:07.222064,  2] ../source3/lib/smbldap.c:794(smbldap_open_connection)
  smbldap_open_connection: connection opened
[2016/02/18 20:12:07.228496,  3] ../source3/lib/smbldap.c:1013(smbldap_connect_system)
  ldap_connect_system: successful connection to the LDAP server
[2016/02/18 20:12:07.229369,  2] ../source3/passdb/pdb_ldap_util.c:287(smbldap_search_domain_info)
  smbldap_search_domain_info: Problem during LDAPsearch: No such object
[2016/02/18 20:12:07.229595,  2] ../source3/passdb/pdb_ldap_util.c:288(smbldap_search_domain_info)
  smbldap_search_domain_info: Query was: dc=drbhome,dc=ca, (&(objectClass=sambaDomain)(sambaDomainName=DRBHOME))
[2016/02/18 20:12:07.229709,  0] ../source3/passdb/pdb_ldap.c:6529(pdb_ldapsam_init_common)
  pdb_init_ldapsam: WARNING: Could not get domain info, nor add one to the domain. We cannot work reliably without it.
[2016/02/18 20:12:07.229806,  0] ../source3/passdb/pdb_interface.c:178(make_pdb_method_name)
  pdb backend ldapsam did not correctly init (error was NT_STATUS_CANT_ACCESS_DOMAIN_INFO)

More information about the samba mailing list