[Samba] ADS domain member: winbind fails [SOLVED]

Stefan G. Weichinger lists at xunil.at
Sat Dec 31 11:28:02 UTC 2016

Am 2016-12-31 um 12:08 schrieb Rowland Penny via samba:

> Samba should recreate the files required, what is the exact command you
> are running to join the domain ?
> Who owns /var/lib/samba and what are the permissions set to ?

SOLVED -> what a journey ;-)

rebuilt several packages on the member server today, perl, mit-krb5, 
samba etc

But what did the change was the clearing of /var/lib/samba, that seems 
to have been the issue since beginning.

I stopped smbd nmbd winbindd

# net ads leave -U Administrator

after successful leave I rm-ed /var/lib/samba (I only left the subdir 
private there) then rejoined the ADS domain.

Now winbindd -i -d10 looks very different ;-)

"wbinfo -u" brings users now.


Thanks all for the help so far, could have thought of doing so earlier 
(well, I did, but did it wrong ...)

I test things now.

Thanks again @ Rowland, Louis, etc


Maybe I come back with another issue later, we saw permission problems 
at editing GPOs. "sysvolreset" and "sysvolcheck" done OK already.

More information about the samba mailing list