[Samba] Samba4 problem with Wndows Domain Trust

Gaiseric Vandal gaiseric.vandal at gmail.com
Thu Dec 22 13:49:32 UTC 2016

I also get the "WBC_ERR_DOMAIN_NOT_FOUND" messages  on domain member 
servers in my classic domain.           This seems to be regardless of 
samba version (3.6.25 or 4.4.5 or 4.5.1) or if I compiled samba or using 
precompiled package.

What I don't understand is why wbinfo seems to work in some cases but 
not others.

On 12/22/16 01:44, Josef Wölfle via samba wrote:
> Hi  Gaiseric,
> "wbinfo -u" does not show the DOMAIN_B users.
> "wbinfo -n DOMAIN_B+someuser"  works and show the SID of the users, 
> also from Domain_B.
> "wbinfo -i DOMAIN_B+someuser" does not work. It only works for users 
> of Domain_A.
> For User of Domain_B, it says:
> failed to call wbcGetpwnam: WBC_ERR_DOMAIN_NOT_FOUND
> Could not get info for user Domain_B+someuser
> "wbinfo --allocate-uid" doesn´t work. It says:
> failed to call wbcAllocateUid: WBC_ERR_DOMAIN_NOT_FOUND
> Could not allocate a uid
> Yes, I also tried ad backend for domain_B with the setting:
> idmap config Domain_B: range = 4000-4999
> Same results as with backend tdb.
> I also tried "winbind rpc only = Yes", but it made no change.
> With hope on further hints, Kind Regards
> Josef

More information about the samba mailing list