[Samba] smbclient returns error when NetBIOS disabled on Windows Server

Andrew Watkins andrew at dcs.bbk.ac.uk
Fri Apr 29 21:29:15 UTC 2016

On 4/29/2016 10:14 PM, Jeremy Allison wrote:
> On Tue, Apr 26, 2016 at 10:18:26PM +0100, Andrew Watkins wrote:
>> Hello,
>> I have noticed that smbclient returns an error code when a windows
>> server has disabled NetBIOS, but should it do this, if you know
>> NetBIOS has been disabled. I think there should be a flag to
>> indicate that you don't want to check port 139 (NetBIOS).
>> For example the following command which tries to connect to a
>> Windows server with NetBIOS disabled returns an ERROR!
>> $ smbclient  -L //bloomsburyfs -U wstudent%password
>> Domain=[DCSNT] OS=[Windows Server 2008 R2 Enterprise 7601 Service
>> Pack 1] Server=[Windows Server 2008 R2 Enterprise 6.1]
>>          Sharename       Type      Comment
>>          ---------       ----      -------
>>          home            Disk      Student home drive share
>>          IPC$            IPC       Remote IPC
>> resolve_lmhosts: Attempting lmhosts lookup for name bloomsburyfs<0x20>
>> resolve_lmhosts: Attempting lmhosts lookup for name bloomsburyfs<0x20>
>> resolve_wins: Attempting wins lookup for name bloomsburyfs<0x20>
>> resolve_wins: WINS server resolution selected and no WINS servers listed.
>> resolve_hosts: Attempting host lookup for name bloomsburyfs<0x20>
>> Connecting to at port 139
>> Error connecting to (Error 0)
>> Connection to bloomsburyfs failed (Error NT_STATUS_UNSUCCESSFUL)
>> NetBIOS over TCP disabled -- no workgroup available
>> But, it would be good if you could tell "smbclient" that you don't
>> want it to check for NetBIOS which means you would not get an ERROR
>> code.
> The code in 4.4.x is quite sophisticated, in that is by
> default tries port 445 and then 5msecs later tries 139.
> So it should be trying 445 by default. What is your
> smb.conf set to, and can you post a debug level 10 log
> from this smbclient command ?

I solved the problem a couple of hours ago.

Well I am using Samba 3.6.x version and after I installed Samba 4.4.x it 
worked fine.
Guess I need to upgrade our systems, but using samba that comes with 
Solaris 11.

Thanks for now.


Andrew Watkins * Birkbeck, University of London * Computer Science *
* http://notallmicrosoft.blogspot.com *
* UKOUG Systems SIG Chair * formaly Solaris SIG *
* UKOUG Systems Event 2016 committee *
* UKOUG Tech committee *

More information about the samba mailing list