[Samba] After Samba update getent returns just local users and groups

Luca Bertoncello lucabert at lucabert.de
Tue Apr 19 07:56:26 UTC 2016

Hi list!

I have Samba 4.3.8 installed from Ubuntu-Repositories on a Ubuntu  
14.04 server.
It worked fine as AD-Controller, then today I performed an update,  
since Ubuntu sayd, that new update are available.

Well, maybe I'll NOT do that anymore, since I have many problem, now...
I solved almost all of them, but this problem unfortunately not...

I use nss and winbind. The users are present and I can login and use  
smbclient, but now getent passwd or getent group returns just local  
users and groups...

Of course I didn't change anything...

My /etc/nsswitch.conf:

# /etc/nsswitch.conf
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc-reference' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd:         compat winbind
group:          compat winbind
shadow:         compat

hosts:          files dns
networks:       files

protocols:      db files
services:       db files
ethers:         db files
rpc:            db files

netgroup: nis
sudoers:        files

Any idea?

Luca Bertoncello
(lucabert at lucabert.de)

More information about the samba mailing list