[Samba] Domain member seems to work, wbinfo -u not (update3)

Rowland penny rpenny at samba.org
Sun Apr 17 15:45:10 UTC 2016

On 17/04/16 14:51, L.P.H. van Belle wrote:
> Ok some new info.
> Yesterday file server worked, print server not.
> Today, both dont work.
> Same test today, proxy1 and proxy2.
> Proxy1 didnt work, proxy2 did ( at that time 4.3.6)
> I upgraded (to 4.3.8) proxy2, tested again, still working.
> Ok, now this proxy 2 is an vm ( a copy of proxy1 ), so lets try something..
> I remove proxy2 from the ad domain (proxy1 is our main proxy) so this one is to test with.
> Cleared up /var/(lib/cache)/samba folders
> Re-added the server to the domain, started samba and winbind, and..
> Same problem here now.

This is getting weird.

> Im thinking its something related to the kerberos keytab file.
> I checked also the (yesterday) working file server, and i did see that
> Only the keytab file was refreshed.
> Since there where no changed on that server, why did it work yesterday and not today.. so keytab related is my guess.
> And i noticed some mount where not automounting on bootup and these use kerberos also.
> Re-creating the keytab file didnt help.

Have you tried leaving the domain, deleting the keytab and then 
re-joining the domain ?

If I remember correctly, you use your own certificates, I don't, I 
wonder if this could be a problem ?


> Tomorrow more testing..
> Greetz,
> Louis

More information about the samba mailing list