[Samba] We are not schema master on all DCs

Johannes Amorosa | Celluloid VFX johannesa at celluloid-vfx.com
Fri Apr 15 07:31:27 UTC 2016

On 04/14/2016 02:09 PM, Thomas Rosenstein wrote:
>> 13 April 2016 at 16:49
>> Well, it sounds like you don't have a schema master, what does 
>> 'samba-tool fsmo show' give as the owner for the SchemaMasterRole ?
>> It might also help if you can give us an instance of what you are 
>> trying to add to the schema.
>> Rowland
> I had a SchemaMaster, it was the first DC and it showed it is the 
> Master - but via LDAP it insisted that it wasn't.
> I moved the SchemaMaster to another DC (that worked!) and then moved 
> it back, and that solved the issue!
> Thanks!!
> Thomas
Sorry for hijacking this thread, do you believe we can fix our issues 
since the upgrade with the
same solution? Our error is different but maybe switching DC and back 
would solve this error mesage:

Failed extended allocation RID pool operation - Failed to modify RID Set 
object CN=RID Set,CN=DC3,OU=Domain Controllers,DC=ourdomain,DC=inc
- objectclass_attrs: at least one mandatory attribute ('rIDNextRID') on 
entry 'CN=RID Set,CN=DC3,OU=Domain Controllers,DC=ourdomain,DC=inc' 
wasn't speci#020#001

Thank you for your time.

Johannes Amorosa | Celluloid VFX

Celluloid Visual Effects GmbH & Co. KG
Paul-Lincke-Ufer 39/40, 10999 Berlin

More information about the samba mailing list