[Samba] Testing AD with first XP client

Robert Moskowitz rgm at htt-consult.com
Fri Sep 11 19:28:14 UTC 2015

On 09/11/2015 02:54 PM, Rowland Penny wrote:
> On 11/09/15 19:27, Robert Moskowitz wrote:
>> On 09/11/2015 02:15 PM, Sketch wrote:
>>> On Fri, 11 Sep 2015, Robert Moskowitz wrote:
>>>> So now I am up to testing the AD from the network.  I am using an 
>>>> XP client (the only Win OS I have here) The notebook is a 'new' 
>>>> load with all patches. It does not have user login control yet (so 
>>>> effectively in as Administrator on it) and workgroup is WORKGROUP.
>>> I take it that means you haven't joined the domain yet.  That would 
>>> be my first step in testing.
>> I am trying first guest workstation...
>>>> Net view /DOMAIN:HOME.HTT
>>>> came back (after a long wait) with:
>>>> System error 6118 has occured.
>>>> The list of servers for this workgroup is not currently available.
>>>> I did set 'guest ok = yes' for the [Demo] share.
>>> I'm not really familiar with the NET commands on Windows 
>>> (particularly VIEW), but /DOMAIN might not work if you're not on the 
>>> domain.
>> I go back to the start of Windows networking.  We did everything from 
>> the DOS prompt.
>>>   You might just try browsing to \\homebase\demo in explorer.  Or 
>>> "net use Z: \\homebase\demo"
>> Good point.  I tried that and actually was asked for user name for 
>> 'homebase'.  So since none of my users got added by classicupdate 
>> (and no one has pointed me to what to look for to troubleshoot this), 
>> I tried 'Administrator' (both cap and lower) and the passwork I use 
>> for samba-tool and got 'password or user name is invalid'  I think 
>> checked with:
>> # wbinfo -u
>> administrator
>> dns-homebase
>> dhcpduser
>> krbtgt
>> guest
>> I also tried guest with no password and that failed.
> Try adding 'map to guest = bad user' to smb.conf on the DC and restart 
> samba

I assumed this goes in the general section.  I put it there, and 
restarted sernet-samba-ad then on XP command again tried:

net use Z: \\homebase\demo

Provided 'guest' as the user and no password and got:

System error 1326 has occured.

Logon failure: unknown user name or bad password.

More information about the samba mailing list