[Samba] Error while changing security permissions on Ubuntu 14.04 with glusterfs 3.4

Adda Rathbone addarathbone at googlemail.com
Sun May 31 13:59:22 MDT 2015

following problem: I am not able to change the security permissions with my
windows client (Windows Server 2008 R2).
I receive "An error occurred while applying security information to
HOST.SAMDOM.EXAMPLE.COM access is denied".
The error occurs with samba and glusterfs as shipped with Ubuntu 14.04.

A (test-) script to reproduce the error can be found on :
(tested with Ubuntu 14.04 and Windows Server 2008 R2)

The script joins an AD and sets up a samba share called test (first with
xfs then with glusterfs). With xfs security permissions can be changed,
with gluster not.
The security permission changes I tried was to remove EVERYONE and add
SYSTEM with full privileges.

I already tried to set the owner of the shared folder as described in
https://lists.samba.org/archive/samba/2014-April/180928.html and
with no success.

Using linux tools (setfattr, setfacl) I am able to change the xattr and acl
in the glusterfs mount point.

Thank you

More information about the samba mailing list