[Samba] Samba4 4.2 building options and error during Samba4 4.2. building breaks it.

CpServiceSPb . cpservicespb at gmail.com
Thu Mar 19 18:25:43 MDT 2015

I tried to build Samba4 4.2.0 from March, 04, 2015 from sources and got the
same error at 2 different machiens with Ubuntu 14.04 server LTS x32:

[3724/4281] Linking default/lib/util/libsamba-util.so
default/lib/util/util_11.o: In function `file_check_permissions':
home/samba/bin/../lib/util/util.c:152: undefined reference to
default/lib/util/util_11.o: In function `directory_create_or_exist_strict':
home/samba/bin/../lib/util/util.c:277: undefined reference to
collect2: error: ld returned 1 exit status

Firstly I built talloc, tdb, tevent and ldb, all are with
--enable-developer --bundled-libraries=NONE switches.
Then Samba4 in its self with:
--enable-developer --enable-gnutls --enable-cups --enable-iprint
--with-regedit --builtin-libraries=replace

And there are not --enable-socket-wrapper --enable-nss-wrapper
--enable-uid-wrapper options of configure.
How are to enable them ?

So what is it and how is avoid it to build Samba4 ?

And are valid --enable-cups and --enable-iprint for Samba4 4.2 ?

More information about the samba mailing list