[Samba] bug in samba 4.1.17 ? changed CNAME record to other host

Peter Serbe peter at serbe.ch
Thu Mar 12 04:09:17 MDT 2015

Hi Louis, 

have You noticed my thread "How to get rid of misspelled DNA entry?" a 
few days ago? You stumbled across exactly the same issue. samba-tool 
doesn't seem to work on DNS entries other than exactly the same domain 
(here: domain.tld - and not: internal.domain.tld). I don't know whether 
this is a bug or just a simple limitation. 

You can manipulate the entries either by using ldbtools or by using 
some LDAP tools. Sebastian pointed me at Apache Directory Tool, which 
solved my issue easily. 

Nevertheless I do agree, that it was better, if samba-tool could access 
these entries without some kind of filtering of the data. 

Best regards

L.P.H. van Belle schrieb am 12.03.2015 10:41:

> Hai, 
> Im testing out with some dns things.. 
> And i think i have seen more people about this.. 
> Debian 7 ( wheezy ) samba 4.1.17 debian backports. 
> only 1 DC, no member, just 1 DC. 
> I have added multiple DNS records and zones with the windows tool. 
> sofare good, works ok... 
> in one of my zones changed the CNAME of a record. 
> for example. 
> websitename1.domain.tld CNAME to serverhostname.internal.domain.tld
> i changed 
> websitename1.domain.tld CNAME to serverhostname2.internal.domain.tld
> I did this this morning a few hours ago.. 
> I noticed now few hours later, my changed records is gone.. 
> but when i want to add a new CNAME for this record, the windows tools says it
> already exists. 
> and a ping to this cname works fine, so the records is there and works. 
> when i run : 
> samba-tool dns query DC.internal.domain.tld domain.tld websitename1 CNAME 
> ( also tested with : samba-tool dns query DC.internal.domain.tld
> domain.tld websitename1.domain.tld CNAME ) 
> result :  Name=, Records=0, Children=0
> now i have 2 cnames to the same host..  
> and 
> samba-tool dns query ADDC.internal.domain.tld domain.tld websitename2 CNAME 
> result : 
> CNAME: websitename2.internal.domain.tld. (flags=f0, serial=2, ttl=3600)
> Did we hit a bug here? 
> Greetz, 
> Louis
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list