[Samba] "failed to lookup DC info for domain over rpc" when joining samba4 domain

Richard Connon richard at connon.me.uk
Mon Mar 9 17:19:53 MDT 2015

On 09/03/2015 22:36, Rowland Penny wrote:
> Hmm, everything looks ok and it shouldn't matter whether you use the 
> standard 3.6 from debian or 4.1.17 from backports except for the fact 
> that 3.6 isn't just old, it is EOL , so you may have to rely on debian 
> backporting any security updates themselves.
> I take it that the three nameservers in the clients resolv.conf are 
> all DC's, if not, I suggest you remove any that aren't, could you also 
> have a look here:
>  https://wiki.samba.org/index.php/Setup_a_Samba_AD_Member_Server
> Rowland

Hi Rowland,

I'm aware of 3.6's security status. I'm planning to count on debian 
backporting fixes for now and move to 4.1 (or 4.2) if and when required.
I have just tried, as an experiment, upgrading this failing client to 
4.1.17 to no avail.

The nameservers in resolv.conf are just forwarders. They forward to my 
DCs for anything under ads.connon.me.uk.
As an experiment I tried changing the resolv.conf on both the DC and the 
client to contain just the DC for this site rather than my normal 
recursive servers. Again, this didn't change the behaviour.

I'm not familiar with the RPC protocol very much. Are there some tools I 
can use to perform some test queries against this DC?


More information about the samba mailing list