[Samba] Users and groups named in Russian disappeared after upgrade samba4 PDC

Vitaly Pyslar pyslarvt at gmail.com
Sun Mar 8 19:06:57 MDT 2015

Hello. I use Ubuntu 11.04. Yesterday I upgraded samba from 
2:4.1.6+dfsg-1ubuntu2.14.04.3 to 2:4.1.6+dfsg-1ubuntu2.14.04.7 with some other 
packages. After restart samda my users and groups named in RUssian have 
disappeared. Neither Windows RSAT shows then, nor samba-tool user list, nor 
wbinfo -u, nor getent passwd, nor pdbedit -L. There are only some users 
available like Administrator, Guest, krbtgt, dhcpd and root. I didn't find any 
related errors in the log files. I can see my lost users and groups in output 
of commands

    ldbsearch -H ldap://localhost -U administrator


    ldapsearch -x -W -H ldap://localhost -D 
'CN=Administrator,CN=Users,DC=mydomain,DC=com' -b DC=mydomain,DC=com

My locale is ru_RU.UTF-8 and I have no any problems with that.
This is the output of testparm:

    Loaded services file OK.
    Press enter to see a dump of your service definitions
            workgroup = MYDOMAIN
            realm = MYDOMAIN.COM
            server role = active directory domain controller
            passdb backend = samba_dsdb
            max log size = 30000
            printcap name = /dev/null
            allow dns updates = nonsecure and secure
            dns forwarder =
            rpc_server:tcpip = no
            rpc_daemon:spoolssd = embedded
            rpc_server:spoolss = embedded
            rpc_server:winreg = embedded
            rpc_server:ntsvcs = embedded
            rpc_server:eventlog = embedded
            rpc_server:srvsvc = embedded
            rpc_server:svcctl = embedded
            rpc_server:default = external
            idmap_ldb:use rfc2307 = yes
            idmap config * : backend = tdb
            printing = bsd
            print command = lpr -r -P'%p' %s
            lpq command = lpq -P'%p'
            lprm command = lprm -P'%p' %j
            veto files = /lost+found/aquota.user/
            map archive = No
            map readonly = no
            store dos attributes = Yes
            vfs objects = dfs_samba4, acl_xattr

samba-tool dbcheck --fix --yes --verbose shows me errors related to my missed 
users "ERROR: Object CN=user name,CN=Users,DC=mydomain,DC=com disappeared 
during check"

samba-tool dbcheck --fix doesn't help.

I started samba-tool dbcheck --cross-ncs --fix --yes --verbose
but it is still processing about some hours.

I can log into domain only with Administrator account.
I tried to downgrade samba, but it didn't help. I also tried to restore my 
domain from backup, but it also didn't help. I spend a lot of time gooling the 
issue and I didn't find anything helpful. Can anybody help me please? Any 
advice would be appreciated.

More information about the samba mailing list