[Samba] setting up W7 profiles

L.P.H. van Belle belle at bazuin.nl
Thu Mar 5 07:00:03 MST 2015


what is the result of ;

If the group domain users does not have any GID, than chgrp does not work. 
chown / chgrp / chmod . only work if you have a UID /GID. 

and if you change the rights from within linux, "After" you did set them from windows.. 
then you can do it again from windows. 

therefore i do also set "acl_xattr:ignore system acl = yes" on the profiles shares. 
and one set, DONT touch it from within linux..   It wil messup your rights if you do.. 




>-----Oorspronkelijk bericht-----
>Van: bob at donelsontrophy.net 
>[mailto:samba-bounces at lists.samba.org] Namens Bob of Donelson Trophy
>Verzonden: donderdag 5 maart 2015 14:26
>Aan: SAMBA MailList
>Onderwerp: [Samba] setting up W7 profiles
>I am setting up W7 profiles following the "Samba & Windows Profiles" on
>the Sambawiki. 
>If it matters, I have two functional DC's and one member server. 
>When I run '# chmod 1770 /srv/samba/profiles' (on the member 
>server) the
>permissions changed to: 
>root at mbr01:~# ls -alh /srv/samba/profiles
>total 12K
>drwxrwx--T+ 2 root root 4.0K Mar 1 10:21 .
>drwxr-xr-t 5 root root 4.0K Mar 1 10:21 .. 
>The first line changed from 'drwxr-xr-t' to 'drwxrwx--T+' and 
>the second
>did not change. 
>Under "Profile share with using POSIX ACLs" it is indicated that we
>should change the '# chgrp „Domain Users" /srv/samba/profiles' I am
>getting "chgrp: invalid group: `Domain Users' " 
>When I run "wbinfo -g" there listed is "domain users". 
>I have tried lower case "# chgrp „domain users" /srv/samba/profiles"
>with the same result "chgrp: invalid group: `domain users' ". 
>Bob Wooden of Donelson Trophy
>615.885.2846 (main)
>www.donelsontrophy.com [1]
>"Everyone deserves an award!!"
>[1] http://www.donelsontrophy.com
>To unsubscribe from this list go to the following URL and read the
>instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list