[Samba] [FIXED] Re: Samba 4.2.x and Fedora 22 (possibly 21 as well) doesn't open kerberos or ldap ports for listening

Trever L. Adams trever at middleearth.sapphiresunday.org
Thu Jul 2 14:56:50 UTC 2015

On 06/29/2015 12:24 PM, Trever L. Adams wrote:
> I compile my own Samba. I have since 4.x was in alpha. I do this because
> of Fedora's decision to not support Samba out of the box with full
> functionality (due to MIT vs. Heimdal which I don't understand, but I am
> sure there are reasons for it). 4.1.x and 4.0.x compiled and worked fine.
> Starting with 4.2.x I have not been able to get a working install. I
> have at least the following installed
>  yum install autoconf automake gcc gdb krb5-devel krb5-workstation openldap-devel make pam-devel python-devel docbook-style-xsl libacl-devel libattr-devel libxslt 
> Additionally, I have gnutls and gnutls-devel installed. The build says
> it is building active directory enabled (I have started specifying
> --with-ads and --with-ldap). On start up it doesn't open the ports to
> listen to kerberos and ldap.
> I have dug around trying to find things on the list or elsewhere.
> Everything I can find is at least a year old and what I find I have
> tried to no avail. I do use the DLZ (-dns on services).
> Is there some trick to getting this to work? I have removed all samba
> related packages that Fedora installs to see if that is the problem. It
> doesn't make any visible change.
> Thank you,
> Trever
Apparently, this is a known bug affecting upgraded provisions (4.0 alpha
-> 4.0 -> 4.1 -> 4.2 in my case).
https://bugzilla.samba.org/show_bug.cgi?id=10991#c9 Run the command
listed and suddenly ldap and kerberos start.

Thank you,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.samba.org/pipermail/samba/attachments/20150702/49b5795e/attachment.pgp>

More information about the samba mailing list