[Samba] CUPS Windows point'n'click driver installation

Mike Ray mray at xes-inc.com
Thu Jan 22 13:24:15 MST 2015

> ----- Original Message -----
> From: "Marc Muehlfeld" <mmuehlfeld at samba.org>
> To: "Mike Ray" <mray at xes-inc.com>, samba at lists.samba.org
> Sent: Thursday, January 22, 2015 2:10:41 PM
> Subject: Re: [Samba] CUPS Windows point'n'click driver installation
> Hello Mike,
> Am 22.01.2015 um 20:11 schrieb Mike Ray:
> > However, for any drivers which I try to install via
> > "Have Disk", I get the error message:
> > 
> > "The folder you specified doesn't contain a compatible
> > software driver for your device. If the folder contains
> > a driver, make sure it is designed to work with Windows
> > for x64-based systems."
> Let me check this. What driver are you using (vendor, model, platform,
> version)? Or better post a link to the download. Then I'll try this to
> reproduce in my test environment. Please also let us know, which
> OS/platform you've tried this on. 
> Regards,
> Marc
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

That failure has reproduced itself with 3 different print drivers, for the following: Lexmark cx510de, Lexmark ms510d, and Hewlett-Packard 5100 dtn.


cx510de: http://support.lexmark.com/index?locale=EN&page=product&userlocale=EN_US&productCode=LEXMARK_CX510&focusedTab=DOWNLOADS#1

ms510dn: http://support.lexmark.com/index?locale=EN&page=product&userlocale=EN_US&productCode=LEXMARK_MS510#1

hp5100dtn: http://h20564.www2.hp.com/hpsc/swd/public/readIndex?sp4ts.oid=74342&swLangOid=8&swEnvOid=4063 (chose PCL6)

Note that the Lexmark downloads are executables; however, when run, you have an option to just extract their contents, allowing you to get access to the driver without installing bloatware.

I have tried to install the drivers using the "Print Management" snap-in available in Windows; I have tried from several different computers, all Windows 7 64-bit. 

As mentioned before, CUPS server is 14.04 running samba 2:4.1.6+dfsg-1ubuntu2.14.04.3 (installed via APT). 

It would take a little bit of time, but if you are so inclined, I could give you a disk image of the CUPS server -- send me an off list email and we can discuss that more.


More information about the samba mailing list