[Samba] Missing Policies folder after failure; how to recreate

James lingpanda101 at gmail.com
Tue Jan 13 13:50:26 MST 2015

Have you tried to reset the permissions?

samba-tool ntacl sysvolreset

On 1/13/2015 3:09 PM, "Gergely, Kaszás" wrote:
> Dear Samba List!
> Long story short and please just don't ask; if it were up to me this 
> would have not happened:
> I need to recreate the default GPO-s (as in the 
> \SysVol\domain.of\Policies\ folder and subfolders) of my domain.
> Trying to delete the old GPO-s I run into errors, both in the windows 
> mmc and on the dc with runing samba-tools as root.
> ERROR(ldb): uncaught exception - LDAP error 50 
> LDAP_INSUFFICIENT_ACCESS_RIGHTS -  <dsdb_access: Access check failed 
> on 
> CN={97A64DB0-B51D-4A70-80A3-7F47483B0EB2},CN=Policies,CN=System,DC=domain,DC=of 
> > <>
>   File "/usr/lib/python2.7/dist-packages/samba/netcmd/__init__.py", 
> line 175, in _run
> Reprovisioning is not an option; since this is an active, "in use" 
> system with lots of accounts.
> The moment this is solved I swear to make a second DC with sysvol 
> replication.
> Thank you!


More information about the samba mailing list