Min Wai Chan dcmwai at gmail.com
Sun Jan 11 13:12:08 MST 2015


I've the same problem but I'm on samba version 4.1.12 and gentoo and also
using bind backend.

However, my result are a bit different.
In my case, the entry cannot be seen from RAT nor can i add/delete the same
name entry (same like you)

However I can still ping or resolve that host name...

That was the strange part...

I would like to know the answer as well.

Min Wai

On Mon, Jan 12, 2015 at 3:46 AM, Sebastian Henrich <
sebastian.henrich at gmail.com> wrote:

> Hallo,
> I'm using Samba 4 AD in production now for more than a half year. All
> works great since today. Today I was unable to access my network
> printer by its hostname. So I looked up his DNS Entry using the
> Windows DNS-Manager and recognized that the DNS entry for the printer
> is missing. I tried to readd it, but got the error message that the
> entry already exists.
> Next I tried to remove an add the entry using samba-tool. Here is what I
> did:
> root at vserver2:~# samba-tool dns query vserver2 int.sebhen.de farbmfp A
> -U administrator
> Password for [SEBHEN\administrator]:
>   Name=, Records=0, Children=0
> root at vserver2:~# samba-tool dns delete vserver2 int.sebhen.de farbmfp
> A -U administrator
> Password for [SEBHEN\administrator]:
> ERROR: Record does not exist
> root at vserver2:~# samba-tool dns add vserver2 int.sebhen.de farbmfp A
> -U administrator
> Password for [SEBHEN\administrator]:
> ERROR(runtime): uncaught exception - (9711,
>   File "/usr/lib/python2.7/dist-packages/samba/netcmd/__init__.py",
> line 175, in _run
>     return self.run(*args, **kwargs)
>   File "/usr/lib/python2.7/dist-packages/samba/netcmd/dns.py", line 1067,
> in run
>     0, server, zone, name, add_rec_buf, None)
> I also restarted Samba and Bind and rebooted the whole VM. Nothing
> solved the problem. After the reboot I'm able to access the printer
> again. So it seems that Samba added it to the dns zone again.
> Does anybody knows this problem and has a solution how to fix it?
> I'm using Samba version 4.1.6 from the Ubuntu 14.04 repositories. My
> DNS backend is Bind.
> Thanks
>   Sebastian
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list