[Samba] Solaris 11 Server does not show up in Windows 7 Network List

Postmaster Postmaster at Hotbray.net
Wed Jan 7 09:56:54 MST 2015

I have several years of experience running Samba on Solaris.

We only use Samba to permit data transfer between the Sun server and users
running PCs by means of transferring files.


We currently have a Sun V240 running Solaris 8 and samba with no problems.

We also have a Sun M3000 running Solaris 10 and Samba with no problems.


I am trying to configure a new Oracle T4-1 server to run Samba.

I am running Samba 3.6.24 on a new Oracle T4-1 Server which is running
Solaris 11.2 on a SPARC.


I have Samba installed and running. I can find network shares by using the
IP address of the Server, as in:


\\\SDrive <file:///\\\SDrive>   #This works


But I cannot find the shares using the server name, as it:


\\SunT4\SDrive <file:///\\SunT4\SDrive>   # This does not work.


If I add an entry in the Hosts file on the PC mapping the server name
(SunT4) to the IP address then I can find the share using the server name.

I do not want to use this as a fix because it will mean I cannot easily
add/remove shares on the PCs.


If I run up CMD (on a PC) and  type NET VIEW I can see all the PCs and the
Sun M3000 and the Sun V240. The SunT4 does not show up.

To me this implies that I need to change something on the SunT4 server to
say "allow me to join the network" but I cannot figure out what.


The SunM3000 is the master browser.

I can ping left, right and centre (all machines can see one another).

I have tried all the obvious like checking the workgroup name (MSHOTBRAY)


The problem seems to be complicated by the fact that Solaris 11 is VERY
different from Solaris 10.

Solaris 11 has its own SMB/CIFS and you can only run either SMB or Samba. I
am definitely running Samba.


When searching for solutions I keep running into the problem that the Oracle
SMB is often referred to as "Samba" and hence any solutions simply do not


Anyone any ideas?




SMB.CONF --------------------------------------------


               workgroup = MSHOTBRAY

               server string = SunT4

        netbios name = SunT4

               security = share

        passdb backend = tdbsam

        name resolve order = host wins bcast 

        browseable = yes

        os level = 100

       dns proxy = no


   comment = User Visible

   path = /uvdrives/pdfs

   writable = yes

   guest ok = yes

   browseable = yes

   force create mode = 0777

   force directory mode =0777

   force security mode=0777

   inherit permissions =yes


(etc for other shares)


More information about the samba mailing list