[Samba] Update

David Holder david.holder at erion.co.uk
Sat Feb 28 12:30:56 MST 2015

Hi Sandy,

Please can you provide the output from an *i**fconfig -a* command?

This should give an idea of what is going on. Turning off IPv6 will not 
be necessary if you can find the actual cause of the problem.

You would not get this error message if you only have a link local 
address configured on your interface. You must have some form of global 

Also, the IPv6 address is that of git.samba.org not samba.org. You could 

*traceroute6 git.samba.org.*

Best Regards,
Dr David Holder CEng FIET MIEEE

Erion Ltd, An Cala, Inverkirkaig, Lochinver, Sutherland, IV27 4LR, UK

Reception: +44 (0)1422 207000

Direct Dial: +44 (0)131 2026317


Registered in England and Wales. Registered Number 3521142
Registered Office: Newtons, 49 Coniscliffe Road, Darlington, County 
Durham, DL3 7EH, UK
VAT Number: GB 698 3633 78

On 28/02/2015 18:38, Reindl Harald wrote:
> Am 28.02.2015 um 19:13 schrieb sandy.napoles at eccmg.cupet.cu:
>> I do not working with ipv6, I have disable, but I have the same error, I
>> can read in internet that this ipv6 ip 2001:638:603:d06e::80:230: belong
>> to url samba.org....
>> If I try to connect to this url using some navegator I connected
>> perfect....but when I run git pull using command line I can not 
>> connect..
> the question is *how* did you disable ipv6 - when ifconfig shows a 
> "link local" ipv6 address the stack is *not* entirely disabled
> [root at srv-rhsoft:~]$ ifconfig eth0
>         ether 24:be:05:1a:c0:27  txqueuelen 100  (Ethernet)
>         RX packets 2460  bytes 577531 (563.9 KiB)
>         RX errors 0  dropped 0  overruns 0  frame 0
>         TX packets 8722  bytes 1981928 (1.8 MiB)
>         TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
>         device interrupt 20  memory 0xf7e00000-f7e20000
>>> Am 28.02.2015 um 15:37 schrieb sandy.napoles at eccmg.cupet.cu:
>>>> Hello list, Iam using samba4 as Domain Controller my verion Version
>>>> 4.3.0pre1-GIT-068f9e2, but I have a little problem when I going to
>>>> update
>>>> using GIT PULL I have this error
>>>> error: Failed to connect to 2001:638:603:d06e::80:230: Network is
>>>> unreachable while accessing http://git.samba.org/samba.git/info/refs
>>>> fatal: HTTP request failed
>>>> some body can helpme
>>> do you have working ipv6?
>>> if not disable it via sysctl.conf
>>> net.ipv6.conf.all.disable_ipv6=1
>>> net.ipv6.conf.default.disable_ipv6=1
>>> that above is most likely because the link-local address if the ipv6
>>> stack is enabled and some piece of software thinks it's useable
>>> -- 
>>> To unsubscribe from this list go to the following URL and read the
>>> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list