[Samba] Internal DNS strangeness in 4.1.16

Rowland Penny rowlandpenny at googlemail.com
Fri Feb 27 11:27:15 MST 2015

On 27/02/15 18:15, Günter Kukkukk wrote:
> Am 27.02.2015 um 17:55 schrieb Greg Dickie:
>> Hi,
>>    I have just provisioned a new samba setup with 2 DCs running ISC DHCPd in failover and I’m trying to get it to play nice with samba internal DNS but I’m having some issues.
>> 1) I’m using on commit, etc triggers in the dhcpd config to call a script that calls samba-tool to add, delete or update DNS. This script works fine when I call it from the command line as the dhcpd user but when called from the dhcpd daemon it throws a WERR_INTERNAL_DB_ERROR which is scary. That is coming from the client I guess. What is the best way to figure out what is going on server side. I increased the log level but I get crazy amounts of info that does not seem relevant.
>> 2) I added a reverse zone 80.16.172.in-addr.arpa and when I add records to it all lookups fail with samba saying it’s not authoritative for the lookup.I figured maybe it was a class B vs Class C thing so I created a 16.172.in-addr.arpa zone and tried that. It’s better, now I just get a SERVFAIL like it can’t find it. If I do a samba-tool query ALL I see records in the AD.
>> I haven’t played with 4 since the early days, it’s come a long way. nice.
>> Any ideas for the problems above?
>> Thanks,
>> Greg
>> -- 
>> Greg Dickie
>> just a guy
>> 514-983-5400
> afair - the internal dns server loads all zones on *startup only*.
> It allows to add new zones - and entries inside - but will "serve"
> them only after a restart (of samba).
> Cheers, Günter
> PS - i don't know whether this behaviour has changed recently...

I totally missed that the OP was using the internal dns server, I could 
never get dhcp to update records using the internal dns server and 
believe me I tried. I just installed bind9 and that worked correctly.


More information about the samba mailing list