[Samba] recreate/re-provision DNS db from scratch?

Bram Matthys syzop at vulnscan.org
Thu Feb 26 13:46:33 MST 2015

Hi Marc,

Good news. I managed to upgrade successfully... (see below)

Marc Muehlfeld wrote on 25-2-2015 21:17:
> Am 24.02.2015 um 22:04 schrieb Bram Matthys:
>> # /usr/local/samba/bin/samba-tool dns zonelist
>> ..
>> Using binding ncacn_ip_tcp:[,sign]
>> Mapped to DCERPC endpoint 135
>> added interface jnet ip= bcast= netmask=
>> added interface wifi ip= bcast= netmask=
>> added interface jnet ip= bcast= netmask=
>> added interface wifi ip= bcast= netmask=
>> ERROR(runtime): uncaught exception - (-1073741801, 'Memory allocation error')
>>   File
>> "/usr/local/samba/lib/python2.7/site-packages/samba/netcmd/__init__.py",
>> line 175, in _run
>>     return self.run(*args, **kwargs)
>>   File "/usr/local/samba/lib/python2.7/site-packages/samba/netcmd/dns.py",
>> line 809, in run
>>     dns_conn = dns_connect(server, self.lp, self.creds)
>>   File "/usr/local/samba/lib/python2.7/site-packages/samba/netcmd/dns.py",
>> line 40, in dns_connect
>>     dns_conn = dnsserver.dnsserver(binding_str, lp, creds)
> Is 4.0.6 the last version, that works? Have you tried just the next (4.0.7)?
> What happens if you connect to the second IP ( instead? Or

First of all, a correction on my side: I see I said I was using 4.0.6,
that's not true. I apologize for the confusion: I was actually using 4.1.6.

Your suggestion to update to next version (in general) got me thinking.
I then upgraded as follows:
4.1.6 -> 4.1.7 -> 4.1.10 -> 4.1.14 -> 4.1.16 -> 4.1.17
And now everything works great! :)

So, not sure what caused it, but by following a more "gradual upgrade path"
(so to speak) it worked.
samba-tool dns zonelist.. etc.. no longer gives any errors. clients can log
in fine, group policy is working, DNS management from MMC works even if I
refresh a 100 times, etc.

Only small issue I had were a few clients which behaved strangely (missing
desktop.. maybe a group policy issue) but they worked after I rejoined them
to the domain. Windows 7. It seems to affect only 2 clients at this point
out of 100+. Not sure why it happens, have seen it happen before after an
upgrade on two different networks/domains, actually, but ah well.. not a big

I'm really glad I'm finally able to run an up to date samba again :)

Thanks again for your suggestion!



Bram Matthys
Software developer/IT consultant        syzop at vulnscan.org
Website:                                  www.vulnscan.org
PGP key:                       www.vulnscan.org/pubkey.asc
PGP fp: EBCA 8977 FCA6 0AB0 6EDB  04A7 6E67 6D45 7FE1 99A6

More information about the samba mailing list