[Samba] gpo update problem

L.P.H. van Belle belle at bazuin.nl
Mon Feb 16 07:50:40 MST 2015

Hi Bob, 

are you running 1 or 2 dc's atm. 
If 2DC's , did you use the sysvol repl script of me. 

check you path in /etc/samba/smb.conf on the DC(s) 
and set it to /home/samba/sysvol 

if you corrected this then restart samba on the DC's. 
and then rerun ( as root of with sudo )  
samba-tool ntacl sysvolreset

and i you have 2 DC's .. 

this :  ls -alh /home/samba/sysvol/ 
looks correct. 

and if you used 2 DC's. 
check the following file 

you should see: 
/usr/bin/rsync -XAavz --log-file /var/log/sysvol-sync.log --delete-after -f\"+ */\" -f\"- *\"  /home/samba/sysvol root@$DC2:/home/samba 

If this line was not correct like: ...  -f\"- *\"  /home/samba/sysvol root@$DC2:/home/samba/sysvol
do the following, stop cron on DC1. 
login on DC2 and remove /home/samba/sysvol completly. 
/root/.unison/  remove the hash files.

DC1. remove the hash files. !! 

Do this wrong and you and up with an empty sysvol !! 
so before removing anything please make a backup of you sysvols on BOTH DC's to be sure. 

Next week in having more time to improve the scripts to make sure its all more clear what to enter where.


>-----Oorspronkelijk bericht-----
>Van: bob at donelsontrophy.net 
>[mailto:samba-bounces at lists.samba.org] Namens Bob of Donelson Trophy
>Verzonden: maandag 16 februari 2015 14:50
>Aan: samba at lists.samba.org
>Onderwerp: Re: [Samba] gpo update problem
>Hum-m-m, yes, there is no file or directory by that name. I do not know
>enough about python to know how it generated that line "ERROR(<type
>'exceptions.OSError'>): uncaught exception - [Errno 2] No such file or
>directory: '/home/samba/sysvol/sysvol/tmpzhDFKI' " 
>There is no '/home/samba/sysvol/sysvol/tmpzhDFKI'. There is no "sysvol"
>directory after '/home/samba/sysvol/' when I "ls". 
>root at dc01:~# ls -alh /home/samba/sysvol/
>total 12K
>drwxr-xr-x 3 root root 4.0K Jan 24 08:29 .
>drwxr-xr-x 3 root root 4.0K Jan 24 08:29 ..
>drwxr-xr-x 3 root root 4.0K Jan 24 08:29 dts***m.lan 
>Starting to look like a 'bug?' 
>Bob Wooden of Donelson Trophy
>615.885.2846 (main)
>www.donelsontrophy.com [1]
>"Everyone deserves an award!!"
>On 2015-02-16 07:06, Marcel de Reuver wrote: 
>> 2015-02-16 4:07 GMT+01:00 Bob of Donelson Trophy 
><bob at donelsontrophy.net>:
>>> I have setup 'profiles' and 'home share' per the 
>instructions on Samba wiki. That seemed to go fine. When I 
>moved on to 'folder re-direction' I tried to open GPO 
>management on my W7 client and received a "User policy could 
>not be updated successfully . . ." on the windows CP console. 
>Started googling the error and ran into "samba-tool ntacl 
>sysvolcheck" so, I ran it and got this:
>> root at dc01:~# samba-tool ntacl sysvolreset
>>> ERROR(<type 'exceptions.OSError'>): uncaught exception - 
>[Errno 2] No such file or directory: 
>> Strange location for sysvol and what does tmpzhDFKI at that location?
>> Regards,
>> Marcel
>[1] http://www.donelsontrophy.com
>To unsubscribe from this list go to the following URL and read the
>instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list