[Samba] Samba 4 and MS Windows NFS Server (2012R2)

Ritter, Marcel (RRZE) marcel.ritter at fau.de
Mon Aug 31 06:43:30 UTC 2015


has anyone out there tried to get a Windows Server 2012R2 based
NFS Server running against a Samba4 active directory?

I'm currently doing some interop testing, and I cannot get a Windows
Server 2012R2 based NFS  server running when using samba as AD.

As far as i can tell, the setup looks good:

I've got Linux based NFS servers and clients  (Ubuntu + SuSE) up
and running fine (krb5 auth against samba DC), but trying to access
the Windows NFS server fails.

Outside the above testbed I've tried to mount NFS shares on a
different Windows Server (joined against our MS AD) and access
from Linux clients works fine here, so I guess it's not MS NFS server
itself that's causing the trouble.

The failing windows NFS Server reports lots of messages like:

"Server for NFS was unable to obtain security information for the
GSS user account MYDOM.TEST\nfs/nfsclient.mydom.test.

Check that the user account MYDOM.TEST\nfs/nfsclient.mydom.test
is valid and meets als configured security policies. Ther may be additional
information in the Windows Security event log.

MSV Status: 0xC000009A, Substatus: 0x0
S4U Status: 0xC000006D, Substatus: 0x0

The security log reports:

"An account failed to log on.

        Security ID:            SYSTEM
        Account Name:           WIN12$
        Account Domain:         MYDOM
        Logon ID:               0x3E7

Logon Type:                     3

Account For Which Logon Failed:
        Security ID:            NULL SID
        Account Name:           nfs/nfsclient.mydom.test
        Account Domain:         MYDOM.TEST

Failure Information:
        Failure Reason:         Unknown user name or bad password.
        Status:                 0xC000006D
        Sub Status:             0xC0000064

Process Information:
        Caller Process ID:      0x4
        Caller Process Name:

Network Information:
        Workstation Name:
        Source Network Address: -
        Source Port:            -

Detailed Authentication Information:
        Logon Process:          NfsSvr
        Authentication Package: MICROSOFT_AUTHENTICATION_PACKAGE_V1_0
        Transited Services:     -
        Package Name (NTLM only):       -
        Key Length:             0

This event is generated when a logon request fails. It is generated on the computer where access was attempted.

The Subject fields indicate the account on the local system which requested the logon. This is most commonly a service such as the Server service, or a local process such as Winlogon.exe or Services.exe.

The Logon Type field indicates the kind of logon that was requested. The most common types are 2 (interactive) and 3 (network).

The Process Information fields indicate which account and process on the system requested the logon.

The Network Information fields indicate where a remote logon request originated. Workstation name is not always available and may be left blank in some cases.

The authentication information fields provide detailed information about this specific logon request.
        - Transited services indicate which intermediate services have participated in this logon request.
        - Package name indicates which sub-protocol was used among the NTLM protocols.
        - Key length indicates the length of the generated session key. This will be 0 if no session key was requested.

For me it looks like Windows NFS server does some additional/different
lookups that fail on a samba backend but succeed against a Windows AD,
but that's just a guess.

Is there an easy way to debug LDAP lookups (and results) in Samba 4 (by
setting a certain log level maybe)?

Any other ideas what could cause this?


BTW, I've tested this with Ubuntu samba package 4.1.6, but also with
latest git version of samba.

More information about the samba mailing list