[Samba] POSIX-Share fails with NFS-mounts

Christian Keck Christian.Keck at macio.de
Mon Aug 24 08:42:57 UTC 2015

Hello all,

my problem has been sorted out meanwhile:
Surprisingly the reason was enabled ACLs on the file system of the NFS-server.
For some reasons this resulted in inaccessible shares in samba while the mounted folders still could be accessed by the users via shell.
However, removing the ACL-structures on the server solved the sharing problems within samba.
Maybe this could help someone else, too.

kind regards,
Christian Keck

Fon: +49 431 67072-179
Fax: +49 431 67072-29
christian.keck at macio.de

macio GmbH                                                     
Am Kiel-Kanal 1
D-24106 Kiel

macio · software engineering & user interface design
Geschäftsführer:  Joern Kowalewski · Jörg Gonnermann · Alexander Friedel
Amtsgericht Kiel · HRB 5832

-----Ursprüngliche Nachricht-----
Von: Andreas Schneider [mailto:asn at samba.org] 
Gesendet: Donnerstag, 30. Juli 2015 12:17
An: samba at lists.samba.org
Cc: Christian Keck
Betreff: Re: [Samba] POSIX-Share fails with NFS-mounts

On Thursday 30 July 2015 09:28:46 Christian Keck wrote:
> Hi there,
> I'm sure this must have been discussed before, but I can't find 
> anything that addresses exactly my problem in the archives.
> The problem I ran into is, that a samba-share relying on POSIX 
> file-permissions stops working as soon as the shared folder is a 
> NFS-mount itself. In that case, it is no longer possible for any user 
> to access files or folders. So in my example, if "/samba/shares" is a 
> local folder, everythings works as expected. If I mount an external 
> storage to "/samba/shares" via NFS, the access from the Windows 
> clients via samba is denied to this share. I need to get this 
> construct running, since for some reason I can't get a customized 
> samba running directly on the storage, so I need to use a dedicated 
> machine for this that mounts the data to be shared somehow. I'm using samba 4.2.1 here.
> Is there a solution for this?
> Many thanks in advance.

It works with a limited feature set, see 'kernel oplocks' in 'man smb.conf'.

However we do not really support this and recommend to solve it this way.

Andreas Schneider                   GPG-ID: CC014E3D
Samba Team                             asn at samba.org

More information about the samba mailing list