[Samba] Samba 4 Bind DNS on CentOS 7

Brady, Mike mike.brady at devnull.net.nz
Fri Aug 21 08:52:42 UTC 2015

On 2015-08-21 18:24, John Gardeniers wrote:
> Hi Mike,
> I originally installed using the built-in DNS. Then, after finding it
> missing most features, I installed Bind and, lacking the named.con,
> tried it including likely sounding files from the Samba setup
> directory (OK, I was getting desperate). I then ran "samba_upgradedns
> --dns-backend=BIND9_DLZ" and discovered that named wouldn't start.
> After removing the include line it did start but of course was missing
> the important AD stuff. I ran updatedb and again tried to locate
> named.conf, again without success. I then reverted back to the
> internal DNS and named.conf is still not to be found.
> I think, just to satisfy my own curiosity, I'll repeat the install on
> another machine and see if I still get the same results. But that's
> something for next week. At long last, it's Friday afternoon. :)
> regards,
> John
> ===snip== most history removed ===
> On 21/08/15 16:02, Brady, Mike wrote:
>> John
>> The files are all there when I do a classic upgrade.  I am working on 
>> a project to just that at the moment.
>> When you did the classic upgrade did you do it with the 
>> --dns-backend-BIND9_DLZ option?
>> If not you could try doing
>> samba_upgradedns --dns-backend=SAMBA_INTERNAL
>> samba_upgradedns --dns-backend=BIND9_DLZ
>> too see if that forces the files to generate.
>> Regards
>> Mike


Named not starting could be permissions.  named runs as the named user 
and doesn't have permissions to access the the /var/lib/samba/private 
directory.  From memory it was one of the directories in the path and 
one of the files in /var/lib/samba/private.  Can't remember which ones 
exactly, but I can have a look on Monday.

No idea why named.conf isn't in /var/lib/samba/private at all though.  I 
have never not had it there when I needed it.



More information about the samba mailing list