[Samba] Samba 4 Bind DNS on CentOS 7

John Gardeniers jgardeniers at objectmastery.com
Fri Aug 21 06:24:20 UTC 2015

Hi Mike,

I originally installed using the built-in DNS. Then, after finding it 
missing most features, I installed Bind and, lacking the named.con, 
tried it including likely sounding files from the Samba setup directory 
(OK, I was getting desperate). I then ran "samba_upgradedns 
--dns-backend=BIND9_DLZ" and discovered that named wouldn't start. After 
removing the include line it did start but of course was missing the 
important AD stuff. I ran updatedb and again tried to locate named.conf, 
again without success. I then reverted back to the internal DNS and 
named.conf is still not to be found.

I think, just to satisfy my own curiosity, I'll repeat the install on 
another machine and see if I still get the same results. But that's 
something for next week. At long last, it's Friday afternoon. :)


===snip== most history removed ===

On 21/08/15 16:02, Brady, Mike wrote:
> John
> The files are all there when I do a classic upgrade.  I am working on 
> a project to just that at the moment.
> When you did the classic upgrade did you do it with the 
> --dns-backend-BIND9_DLZ option?
> If not you could try doing
> samba_upgradedns --dns-backend=SAMBA_INTERNAL
> samba_upgradedns --dns-backend=BIND9_DLZ
> too see if that forces the files to generate.
> Regards
> Mike

More information about the samba mailing list