[Samba] Solaris 11 can't join Active Directory Domain

dave.stevenson at durham.ac.uk dave.stevenson at durham.ac.uk
Wed Aug 5 15:10:49 UTC 2015

Old thread but still an ongoing problem from time to time I think and Oracle
docs didn't help

I was seeing similar problems  with Solaris11 (July2015) joining 2008R2
client/server_lmauth_level=4, idmap identity mapping setup for "idmu"

smbadm join -u Administrator <DOMAIN>

Apparent problem with Kerberos (password exchange problem)
  smbns_kpasswd: KPASSWD protocol exchange failed () (Cannot contact any KDC
for requested realm)

Try joining the domain with a different account that has UNIX attributes and
has the delegated right to join machines to the domain and has write
permission to the container holding the machine account.
smbadm join -u AnotherUser <DOMAIN>

Worked first time.
Tried with Administrator again - failed - suggests that there may be an
issue with mapping? Also noted that Solaris11 "knows" well known account
names in idmap-ing and may manipulate them differently.

View this message in context: http://samba.2283325.n4.nabble.com/Solaris-11-can-t-join-Active-Directory-Domain-tp4643480p4689510.html
Sent from the Samba - General mailing list archive at Nabble.com.

More information about the samba mailing list