[Samba] vs_fruit - can't write to share

Christian Kovacic, MA chris.k at gmx.at
Sat Apr 25 04:16:19 MDT 2015


i'm running Samba 4.2.1 compiled from source on an Ubuntu 10.04.4 LTS Server. ACL/XATTR is active and working. I tried to activate the vfs_fruite module and added the sample code:

vfs objects = catia fruit streams_xattr
fruit:resource = file
fruit:metadata = netatalk
fruit:locking = netatalk
fruit:encoding = native

to the share. In addition i tried the following share definition:

vfs objects = catia fruit streams_xattr
fruit:locking = netatalk
streams_xattr:prefix = user.
streams_xattr:store_stream_type = no
kernel oplocks = no

The other definitions i use are:

admin users = @filetest
valid users = @filetest
writable = yes
guest ok = no
force user = root
force group = basegroup
create mode = 0775
directory mode = 0775

It is not possible to write to the share at best at the first time i click on save. Sometimes i get 0 Byte files and with a plain text file the initial content is saved. Trying to save a file again results in an error that writing to the share isn't possible (resource busy says TextMate ...).

When starting up Samba i see this error:

Apr 25 12:09:28 SERVERNAME smbd[13730]:   error reading meta xattr: Operation not supported

Which is somehow funny as XATTR are definitely working, followed the instructions in the last past:

Maybe this error could help resovle the issue:

Apr 25 12:12:25 SERVERNAME smbd[13914]: [2015/04/25 12:12:25.841615,  2] ../source3/modules/vfs_fruit.c:902(ad_header_read_rsrc)
Apr 25 12:12:25 SERVERNAME smbd[13914]:   Operation not supported: bad size: 0

I really hope Ralph Böhme could help here.



More information about the samba mailing list