[Samba] Unable to browse system shares of a newly migrated AD DC

Andrey Repin anrdaemon at yandex.ru
Fri Apr 3 08:04:16 MDT 2015

Greetings, Rowland Penny!

>>> I'm trying final steps of my long upgrade process, but I've got hit by the
>>> unexpected.
>>> When everything seemingly run fine in the end, I'm unable to browse the local
>>> shares of the DC.
>>> # smbclient -L localhost -U%
>>> Domain=[CCENTER] OS=[Unix] Server=[Samba 4.1.11-Ubuntu]
>>>          Sharename       Type      Comment
>>>          ---------       ----      -------
>>> Error returning browse list: NT_STATUS_ACCESS_DENIED
>>> Domain=[CCENTER] OS=[Unix] Server=[Samba 4.1.11-Ubuntu]
>>>          Server               Comment
>>>          ---------            -------
>>>          Workgroup            Master
>>>          ---------            -------
>> Turned out, the /tmp directory was not accessible to the user "nobody" for
>> some mysterious reason. (So that
>> sudo -u '#65534' ls -l /tmp || echo 'Fail!'
>> resulted in "Fail!")
>> Repeating the tests with freshly generated setup turned out successfully.
>> At least, in this specific case.

> I said that you probably had a problem with /tmp 3 days ago (but not in 
> those words)

It wasn't an apparent problem. Access mask was fine, no other apps were
harmed. If not for my desperation, I may have just dropped it altogether and
turned to look for different solutions.
But when I tried to recreate the entire setup from scratch, it miraculously
worked as expected.
I still have the original image backup, so if anyone want to investigate, send
me your DSA fingerprint in private, and I'll arrange access to the instance.

With best regards,
Andrey Repin
Friday, April 3, 2015 17:00:37

Sorry for my terrible english...

More information about the samba mailing list