[Samba] Forward lookup DNS Issues samba 4.1.12-9 el6

Sven Schwedas sven.schwedas at tao.at
Mon Sep 29 05:28:29 MDT 2014

I ran into the same problem, cf.

In the end I went for the same workaround as Mourik – a dedicated
caching DNS server that uses the DCs solely for resolving internal
(reverse) domains. I'm not really happy with this setup, but it works
far better.

On 2014-09-29 12:54, Neil wrote:
> Hi guys,
> Thanks for the responses and suggestions.
> Harry you mentioned you also had the same problem, MJ did you
> experience the same problem and is that why you also have the internal
> caching DNS servers?
> I just want to try find out how many people experience this issue and
> if it's a known issue?
> Thanks.
> Regards.
> Neil Wilson.
> On Mon, Sep 29, 2014 at 12:28 PM, mourik jan heupink - merit
> <heupink at merit.unu.edu> wrote:
>> What we have:
>> One (or wto) internal caching dns server pointing to the samba dc's plus to
>> external dns servers.
>> (samba4 'normally' with own internal dns, we did not switch to bind there)
>> Then all clients use this caching dns server, plus an external for extra
>> reliability.
>> MJ
>> On 09/29/2014 12:04 PM, Harry Jede wrote:
>>> On 11:55:13 wrote Neil:
>>>> Hi guys,
>>>> I know this sounds vague and I'll try to explain in more depth now,
>>>> but firstly, does Samba4 internal DNS, cache any records that were
>>>> looked up from a forwarder, and then secondly what is the default
>>>> timeout for waiting for a DNS lookup off of a DNS forwarder?
>>>> I've installed two new Samba4 PDC's(using the built in DNS server and
>>>> not named) for two separate sites, and both had an existing DNS
>>>> server using named configured with multiple forwarders and both
>>>> sites retained the existing named DNS servers and forwarders. Since
>>>> the Samba4 PDC's went in users now have their DNS's set to the
>>>> Samba4 machines and nothing else. Then the Samba4 is configured to
>>>> just lookup any Internet names it doesn't know about via the single
>>>> forwarder off of the older caching named servers.
>>>> Sporadically I seem to get an instant DNS resolution failure(almost
>>>> like my named caching DNS server wasn't even checked), but if you
>>>> refresh or run the same ping again, the name then resolves straight
>>>> away. I can understand if a DNS name doesn't resolve straight away
>>>> due to line speed issues or packet loss, but usually I'd expect this
>>>> would take a few seconds to timeout and not fail instantly.
>>>> If I use my old named caching DNS server I don't get the same
>>>> behaviour, does anyone know why we would experience this?
>>> No,
>>> but I have had a similiary situation some weeks ago. I solved the
>>> problem this way:
>>> switch from internal DNS to bind8 or bind9 with DLZ, see samba wiki
>>> declare this bind instance as "forward only"
>>> make your current internal forwarders a slave for your samba DNS
>>>> Thank you.
>>>> Regards.
>>>> Neil Wilson.
>> --
>> To unsubscribe from this list go to the following URL and read the
>> instructions:  https://lists.samba.org/mailman/options/samba

Mit freundlichen Grüßen, / Best Regards,
Sven Schwedas
TAO Beratungs- und Management GmbH | Lendplatz 45 | A - 8020 Graz
Mail/XMPP: sven.schwedas at tao.at | +43 (0)680 301 7167

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 648 bytes
Desc: OpenPGP digital signature
URL: <http://lists.samba.org/pipermail/samba/attachments/20140929/ac7f3e69/attachment.pgp>

More information about the samba mailing list