[Samba] Problem adding DCs

Sketch smblist at rednsx.org
Fri Sep 26 17:39:51 MDT 2014

I'm having some weird issues trying to add a 3rd DC to my domain.  All 
machines are on CentOS 6.5 running Samba 4.1.11 from sernet.  No problems 
with my existing two DCs (as far as I know).  However, I tried to add a 
3rd DC, and in samba-tool drs showrepl I see errors like this on my 
existing DCs:

    Last attempt @ Fri Sep 26 17:48:14 2014 CDT failed, result 8 (WERR_NOMEM)

on the new DC, an attempt to run the same command gives me the following 

ERROR(<class 'samba.drs_utils.drsException'>): DRS connection to newdc.mydomain.com failed - drsException: DRS connection to newdc.mydomain.com failed: (-1073741801, 'Memory allocation error')
   File "/usr/lib64/python2.6/site-packages/samba/netcmd/drs.py", line 39, in drsuapi_connect
     (ctx.drsuapi, ctx.drsuapi_handle, ctx.bind_supported_extensions) = drs_utils.drsuapi_connect(ctx.server, ctx.lp, ctx.creds)
   File "/usr/lib64/python2.6/site-packages/samba/drs_utils.py", line 54, in drsuapi_connect
     raise drsException("DRS connection to %s failed: %s" % (server, e))

It seems unlikely this is actually a memory error.

new DC:

# free -m
              total       used       free     shared    buffers     cached
Mem:         32068       1880      30187          0        155       1036
-/+ buffers/cache:        688      31380
Swap:        16103          0      16103

old DC (second one is similar):

# free -m
              total       used       free     shared    buffers     cached
Mem:          7868        678       7189          0         75        172
-/+ buffers/cache:        430       7437
Swap:         4031         38       3993

I set the debug level to 9 and see output repeating like this on the new DC:

[2014/09/26 17:51:27.850640,  3] 
   Terminating connection - 'dcesrv: NT_STATUS_CONNECTION_DISCONNECTED'
[2014/09/26 17:51:27.850673,  5] 
   imessaging: cleaning up /var/lib/samba/private/smbd.tmp/msg/msg.62685.39
[2014/09/26 17:51:27.850724,  3] 
   single_terminate: reason[dcesrv: NT_STATUS_CONNECTION_DISCONNECTED]

and output like this on the existing DCs:

[2014/09/26 17:57:45.845720,  4] ../source4/dsdb/repl/drepl_notify.c:196(dreplsrv_notify_op_callback)
   dreplsrv_notify: Failed to send DsReplicaSync to <GUID>._msdcs.mydomain.com for CN=Schema,CN=Configuration,DC=mydomain,DC=com - NT_STATUS_NO_MEMORY : WERR_NOMEM

Also note that this is the second time around that I'm attempting this. I 
initially thought this was just a problem with the join or the install, 
and went in and, since a demotion fails due to the out of memory errors, I 
went in and manually removed all of the entries for that DC using ldbedit 
on my master.  However, I am seeing exactly the same thing again, and this 
is a different install is on a different machine, so I thing I can rule 
out installation issues.  I followed the instructions on the wiki for 
joining an additional DC, just as I did for my second DC, which worked 
fine then.

Any suggestions?

More information about the samba mailing list