[Samba] Need help: Impossible to demote/remove a Secondary Windows DC from my Samba 4 AD DC domain

Martinx - ジェームズ thiagocmartinsc at gmail.com
Wed Sep 10 18:01:08 MDT 2014


I have a up and running Samba4 as an AD DC, along side with 3 Domain
Controllers, like like:

1- Master - ubuntu-ad-1.sambadom.company.com -  Ubuntu Trusty + Samba
4.1.11 + Bind9

2- Slave - ubuntu-ad-2.sambadom.company.com -  Ubuntu Trusty + Samba
4.1.11 + Bind9

3- Slave - ubuntu-ad-3.sambadom.company.com -  Ubuntu Trusty + Samba
4.1.11 + Bind9

4- Slave - pdwad-1.sambadom.company.com - Windows 2k8 R2 + ADDC + DNS Server

Now, I need to "remove / demote / delete" the "pdwad-1" from acting as an
DC but, I'm stucked, it doesn't leave and I am unable to remove it.

So far I tried this:

1- http://technet.microsoft.com/en-us/library/cc771844(v=ws.10).aspx

2- But, "pdwad-1" did not leave, the step 11 did not finished okay, look:

 2.1- Trying to demote / remove W2k8 DC out from the domain:

 2.2- It fails in the end: http://i.imgur.com/qrtsqIg.png

 As you guys can see, it doesn't work, I am unable to remove a W2k8 DC from
my Samba 4 AD DC Domain.

 Then, I started to think about this situation... I come to the conclusion:
hey, I can just shutdown W2k8 (pdwad-1), then go to "ubuntu-ad-1" to try to
remove a "crashed" DC, it did not worked either, now, I'm facing the
following BUG:



 So, in the end of the day, I'm stucked, it is impossible to remove/demote
a W2k8 from a Samba4 AD DC domain...

 Any tips?!


More information about the samba mailing list