[Samba] join fails: invalid server state [SOLVED]

Lars Hanke debian at lhanke.de
Tue Oct 21 14:00:02 MDT 2014

After restarting the Samba4 AD DC I tried again and the issue 
disappeared. However, I couldn't notice any other service of the AD DC 
that looked compromised before.

Am 20.10.2014 22:27, schrieb Lars Hanke:
> I'm launching the final phase of getting my new Samba4 AD DC productive.
> I wanted to join the first real workstation, but it failed:
> # net ads join -U Administrator
> Enter Administrator's password:
> Failed to join domain: failed to lookup DC info for domain
> 'AD.MICROSULT.DE' over rpc: Invalid server state
> This issue was reported already here:
> https://lists.samba.org/archive/samba/2012-July/168212.html, but
> following the tips there neither changed any DNS info involved nor did
> the trick.
> Some verified facts about my setup:
> 1) I have joined other systems to the AD DC.
> 2) If I enter a wrong password, I get a different error message, i.e.
> the server is actually contacted.
> 3) I can do a kinit Administrator successfully, i.e. Kerberos is running
> fine.
> 4) The variants of hostname [-f] [-d] [-s] report correctly.
> 5) Forward and backward resolution of both the AD DC and the client work
> correctly. For the client this is achieved by an entry to /etc/hosts,
> since it has not yet joined, i.e. is missing in the DNS of the AD DC.
> 6) The host -t SRV queries also report correctly.
> What does the message "invalid server state" want to tell me?
> Thanks for your help,
> - lars.

More information about the samba mailing list