[Samba] DNS Issues when joining a Domain as a DC

L.P.H. van Belle belle at bazuin.nl
Thu Oct 16 05:26:24 MDT 2014

the debian version os samba in backports 4.1.11 
does not create the DC Hostname  not correcly  in the DNS.
the first DC is ok, but every other join is missing important dns settings. 

I advice to use sernet samba version 4.1.12 which works perfect for the DC Servers. 
A member server can be samba backports. 

i have tested this a week ago. 

you may want to try my scripts or have a look in the scripts what is done there.




>-----Oorspronkelijk bericht-----
>Van: listen at hueper.de [mailto:samba-bounces at lists.samba.org] 
>Namens Thomas Kempf
>Verzonden: donderdag 16 oktober 2014 11:35
>Aan: samba at lists.samba.org
>Onderwerp: [Samba] DNS Issues when joining a Domain as a DC
>yesterday i tried to join a domain as a DC with bind9 as 
>dns-backend on 
>Debian Wheezy with samba 4.1.11 from backports. I followed the 
>in the wiki https://wiki.samba.org/index.php/Join_a_domain_as_a_DC but 
>didn' find the instruction completely clear, so perhaps i made 
>a mistake 
>during the join.
>It is written there:
>"If you choose BIND as DNS backend, instead of the internal DNS, then 
>you, of course, have to finish this before you continue"
>I could not figure out how to finish configuring bind as a 
>backend, when 
>the keytab file and the other bind-related files get created after 
>joining the domain.
>So i ran the join command first, and with the files created in this 
>step, i was able to get the DC up and running...
>I had to manually create the A and CNAME records on the old DC like it 
>is written in the wiki in the part "Check required DNS entries of the 
>new host". my guess was, that those entries should be replicated later 
>on to the new DC seems not to work.
>When i check the name resolving of the A record on the newly joined DC 
>it does not resolve whereas on the old one it works fine.
>AD-Domain is ad.hueper.de
>old DC is dns2.ad.hueper.de
>new DC is dns1.ad.hueper.de
>dns1:~# host -t A dns1.ad.hueper.de dns2.ad.hueper.de
>Using domain server:
>Name: dns2.ad.hueper.de
>dns1.ad.hueper.de has address
>dns1:~# host -t A dns1.ad.hueper.de dns1.ad.hueper.de
>Using domain server:
>Name: dns1.ad.hueper.de
>Host dns1.ad.hueper.de not found: 3(NXDOMAIN)
>When i look at the servers using RSAT DNS-Manager i can see 
>the A-Record 
>on both DNS-Servers, so i wonder why doesn't it resolve on the new DC ?
>Is it save to delete the A and CNAME Records and recreate them 
>using RSAT ?
>kind regards
>To unsubscribe from this list go to the following URL and read the
>instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list