[Samba] Fwd: Re: Samba_internal dns Ubuntu 14.04.1LTS

Donelson Trophy bob at donelsontrophy.net
Fri Nov 7 08:38:27 MST 2014


Sent the following only to Rowland by mistake. 

Forgive me O' fearless leader of mailing list. 

My bad. 



Bob Wooden of Donelson Trophy

615.885.2846 (main)
www.donelsontrophy.com [1]

"Everyone deserves an award!!"

-------- Original Message -------- 

 		Re: [Samba] Samba_internal dns Ubuntu 14.04.1LTS

 		2014-11-07 09:32

 		Donelson Trophy <bob at donelsontrophy.net>

 		Rowland Penny <rowlandpenny at googlemail.com>

 		awards at donelsontrophy.net

Originally I tried CentOS 6.5 Samba4 ADDC and all went well. But, all my
other machines are Ubuntu. Have tried a few Debian test installs. As
Debian is (was) the parent for Ubuntu, I like it better than CentOS as
an alternate OS. And I know more about how to do this and that in Ubuntu
than CentOS. Not that I am saying anything is wrong with CentOS. I am
just not use to configuring CentOS. (Not an opinion, just a personal

Rowland, based on your suggestion this weekend a Debian Samba4 install
gets built. 

L.P.H. van Belle, based on your suggestion Debian 7.7. I hope there are
some good howtos around. Guess I'll go look, now. (Rowland . . v7.5 . .
v7.7 . . . it's all good!!) 

Thanks both of you. 

(Too many confusing tutorials around for the Ubuntu setups!) 



Bob Wooden of Donelson Trophy

615.885.2846 (main)
www.donelsontrophy.com [1]

"Everyone deserves an award!!"

On 2014-11-07 08:42, Rowland Penny wrote: 

> On 07/11/14 14:14, L.P.H. van Belle wrote:
> ... When using Ubuntu 14.04 as the Samba4 ADDC what is the correct settings? Install debian 7.5 and samba from backports :-D LoL.. .almost correct Rowland.. Install debian 7.7 and samba from sernet :-P imo sernet samba is the best on debian. i had problems with samba 4.1.11 from backports when joining an extra DC. i missed some dns entries, should be fixed in the next 4.1.12 or 13 on backports. 4.1.13 is in Debian Jessie, so should not take long anymore..

Well if you are going to be like that about it, travel back in time
about 2 months, install debian 7.5, install samba 4.1.9 from backports
and provision, return to now and update to 4.1.11, all you have to do
now, is wait until 4.1.13 gets into backports :-D :-D


PS, I cannot recommend using Ubuntu 14.04.

> .... 
>> # Need to keep entry or DNS fails mysrvr03.mycomapny.biz wdnsrvr03 mysrvr03.mycompany.biz wdnsrvr03
> This all has to do with an incorrect setup of ubuntu. * not your fault but ubuntu's. The ubuntu installer is just not correct, and i can get the installer to make it fail on every boot, even when the install is 100% correct. You want to try, get a ubuntu server, choose expert install, expert Command line install. choose minimal install, only ssh-server. nothing else. Install your server, at dhcp ip, press cancel, and now you can enter a static ip. resume the install.. and at last, reboot, and you end up like. 1) slow on network configuring, always waiting, and when fully started, no ssh logins are possible. google for it, lots of people experiance this. 2) you have lost your usb keyboard. same here.. google for it. ( a fix i to put the usb hid in modules before grub install ) Well this always happens to me if i install ubuntu server when i want a minimal install. :-(( This since ubuntu 12.10 and up. in 12.04 this worked fine. and this is why i dont like ubuntu, i did report
but they just wont fix it. When i do exacly the same on a debian install, it works... always. when you use the "standard" ubuntu install you server works fast, but lots extra's is installed which i dont like. so get the resolving correct on you ubuntu and it wil work fine. based on the asumption that you dont run a gui.. and you work from CLI. apt-get remove --purge resolvconf dnsmasq fix /etc/hosts localhost localhost.localdomain ip_server FQDN-server hostnameserver fix /etc/resolv.conf point nameserver to or or the server ip. test hostname -s test hostname -d test hostname -f test hostname -y ( which probely wil fail ) fix 1 , setup nis, found in the list fix 2 , give the kernel the local domain info. see /etc/sysctl.conf #kernel.domainname = example.com reboot and try again. i did the same on my home server ( ubuntu 14.04 with Kodi on it and samba 4 from sernet ) and when setup as it should, the samba installs works fine witout any hassle. When i have t
 he time
i'll make a howto for it. Greetz, Louis 
>> -----Oorspronkelijk bericht----- Van: bob at donelsontrophy.net [mailto:samba-bounces at lists.samba.org] Namens Donelson Trophy Verzonden: vrijdag 7 november 2014 14:26 Aan: samba at lists.samba.org Onderwerp: [Samba] Samba_internal dns Ubuntu 14.04.1LTS I am having problems getting dns to function correctly with Ubuntu 14.04LTS. My /etc/hosts file is: localhost # Need to keep entry or DNS fails mysrvr03.mycomapny.biz wdnsrvr03 mysrvr03.mycompany.biz wdnsrvr03 # The following lines are desirable for IPv6 capable hosts ::1 localhost ip6-localhost ip6-loopback ff02::1 ip6-allnodes ff02::2 ip6-allrouters My /etc/network/interface is: # This file describes the network interfaces available on your system # and how to activate them. For more information, see interfaces(5). # The loopback network interface auto lo iface lo inet loopback # The primary network interface auto eth0 iface eth0 inet static address netmask 255.255.255.
network broadcast gateway dns-nameservers # dns-nameservers # dns-nameservers # dns-search mycompany.biz My /etc/samba/smb.conf is: # Global parameters [global] workgroup = MYCOMPANY realm = MYCOMPANY.BIZ netbios name = MYSRVR03 server role = active directory domain controller # dns forwarder = dns forwarder = # dns forwarder = idmap_ldb:use rfc2307 = yes allow dns updates = nonsecure and secure # from blogging.dragon.org.uk # stops the syslog being spammed by lack of a CUPS server printing = CUPS printcap name = /dev/null idmap_ldb:use rfc2307 = yes idmap config MYCOMPANY:backend = ad idmap config MYCOMPANY:schema_mode = rfc2307 idmap config MYCOMPANY:range = 10000-29999 idmap config *:backend = tdb # this range must not overlap the MYCOMPANY:range above idmap config *:range = 50000-60000 # Use home directory and shell informatio
 n from
AD winbind nss info = rfc2307 [netlogon] path = /var/lib/samba/sysvol/mycompany.biz/scripts read only = No [sysvol] path = /var/lib/samba/sysvol read only = No [Users] path = /Shares/DTUsers comment = domain users folders 4 re-direction read only = No [Profiles] path = /Shares/Profiles comment = domain users profiles read only = No [Media] path = /Shares/Media comment = music, video, etc. read only = No [Software] path = /Shares/Software comment = software installation files read only = No Okay, so notice the various "comment out" entries. I keep reading and trying to 'get my head' around the various combinations. It seems many tutorials (on Internet) keep contradicting themselves. One author did his/hers this way, that author did his/hers that way, etc. When using Ubuntu 14.04 as the Samba4 ADDC what is the correct settings? Suggestions? -- ------------------------- Bob Wooden of Donelson Trophy 615.885.2846 (main) www.donelsontrophy.com [1] [1 [1]] "Everyone deserves an awa
Links: ------ [1] http://www.donelsontrophy.com [1] -- To unsubscribe from this list go to the following URL and read the instructions: https://lists.samba.org/mailman/options/samba [2]

[1] http://www.donelsontrophy.com
[2] https://lists.samba.org/mailman/options/samba

More information about the samba mailing list